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Abstract
The Wavemaker software tool by John Foster allows one to convert the image of some waveform into the
arbitrary waveform file format for a Syscomp signal generator. This application note provides a quick start guide
to using Wavemaker.

Introduction
The Syscomp CircuitGear 101 (figure 1), CircuitGear Mini, and Waveform Generator WGM-201 1 are all capable
of generating an arbitrary waveform. This can be extremely useful in the development of other instruments. For
example:

Figure 1: Syscomp CircuitGear
Cardiac Monitor An artificial cardiac waveform is used to test a cardiac monitor. The artificial version is operated at different frequencies. The waveform is applied to bandpass filter design to check the operation. For
1 Syscomp

Electronic Design, www.syscompdesig.com.

1

convenience, the testing is done at 10 or 100 times the real frequency, and then the results scaled for the
final design.
EEG Signal Real EEG signals are very weak, so that capturing the signal requires sophisticated instrumentation.
Instead of capturing the real signal, one finds an image of the eeg waveform, creates an arbitrary waveform
version, and then uses that for preliminary testing of preamplifiers and filters.
Current Waveform Power equiment current waveform is distorted by non-linear transformer core behaviour or
a non-linear electronic load. The current waveform is captured in a screenshot (see the Syscomp application
note Measuring AC Current and Power Factor) and then used as an arbitrary waveform for a signal generator. The current waveform is then be used as a test signal for filters or electronic power factor correction
circuitry.
From Scope to Generator A waveform that is displayed on an oscilloscope2 screen is captured to a screenshot.
The screenshot is then used to create an arbitrary waveform for the generator.
Audio Demonstrations A series of waveforms is drawn (by hand or by computer program) to contain different
magnitudes and phases of harmonics. These are then digitized and generated by the waveform generator
through a loudspeaker, to indicate the effect on timbre.

Format of the Arbitrary Waveform
Syscomp waveform generators use a very simple format for the arbitrary waveform. The waveform consists of 256
points, each having an 8 bit (0 to 255) value. Zero is maximum positive, 255 is maximum negative. Waveforms
should be scaled so that they use most of this dynamic range, that is, the most positive value is close to zero and
the most negative close to 255. The waveform generator hardware can adjust the amplitude and frequency.
The arbitrary waveform file is a text file that can be edited in any text editor. Each value is on its own line, that
is, the file has 256 lines, each one terminated by a carriage-return line-feed pair. There is no terminating character
at the end of the file.
To use the arbitrary waveform, it is most convenient to place the file in the same directory as the source code.
Then use the Custom button to select an arbitrary waveform. A file selector dialog pops up. Select the arbitrary
waveform file and it will then load into the generator. Adjust the amplitude and frequency as you would do for
any other waveform.

Methods of Creating an Arbitrary Waveform File
Manual If the file is simple, then you can use a text editor to create it by hand. For example, a series of zero
values followed by a series of 255 values creates a pulse of some duration. Use copy and paste to create the
required number of entries.
Editing a waveform file is a useful technique for tweaking the contents of the file. For example, it can
be useful to hand-edit the first few and last few values to make a smooth transition between cycles of the
waveform.
Programmed Mathematical Formula Write a computer program in some language, such as BASIC, to open
a file for write, create the file values according to some formula, and then close the file. This would be
the preferred technique for creating something like a raised cosine pulse, for example. You will need to
ensure that the values written by the program are in integer format (not floating point, which is the native
mathematics of many computer languages). The values also need to be scaled from 0 to 255.
Spreadsheet Create a spreadsheet column with 256 entries. Create a formula for each row entry that generates
the desired value in that row. It may be convenient to create multiple columns, where the additional columns
do operations like scaling and taking the integer part.
2 We assume here a computer-based oscilloscope, such as the Syscomp CGR-101. For an analog oscilloscope, one could capture the screen
image with a photograph and then scan the photograph.
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Then save the spreadsheet as a text or comma-separated-value (csv) file. Load the file into a text editor and
do the final formatting - such as removing commas.
Wavemaker: Draw the Waveform The Wavemaker program allows the operator to draw the arbitrary waveform
by hand. This would be useful where the desired waveform cannot be described by a mathematical formula.
Wavemaker: Auto-Trace the Waveform Wavemaker has the capability of converting a waveform image file
into an arbitrary waveform file. This is very valuable, because it allows one to convert a ‘found image’ into
a waveform. Furthermore, if one has access to a scanner, it is possible to do a drawing of the waveform on
paper, scan the waveform to an image, and then convert that waveform image to an arbitrary waveform file.

Auto-Tracing with Wavemaker

Figure 2: Wavemaker: Opening Screen
John Foster, the author of Wavemaker, has written an excellent manual for the program. That should be
consulted for the full set of controls and options. Here we present a set of quick-start instructions for automatically
converting a drawing of a waveform to an arbitrary waveform file.
1. Install Tcl. Wavemaker is written in the Tcl (tickle) language. You must have the Tcl interpreter installed
on your computer to execute the program. The Tcl interpreter is a program called wish. To determine if
wish is installed on your machine:
• On a Linux machine, execute which wish. If the answer is a path like
/opt/ActiveTcl-8.5/bin/wish
then it’s installed.
• On a Windows machine, look in the Programs directory. On my machine, it’s listed as
ActiveState ActiveTcl8.5.8.1
with a further subdirectory containing Wish85, so it’s installed.
If it’s not installed, go to the ActiveState website:
http://www.activestate.com/activetcl
Download the free version for your operating system and install that. You should now be able to start the
wish interpreter from a command line or by double clicking on it. Also, double-clicking on a file with a
.tcl suffix should automatically invoke wish to interpret the file.
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2. Obtain the Waveform Image
From the Web Right click on the image and with luck a Save Image option will appear. You may have
to convert the format (see below.)
From Computer-Based Oscilloscope Screenshot Use the <alt><printscr> buttons to capture a screenshot. On a Windows machine, start Accessories -> Paint and use the Edit -> Paste
command to paste it into Paint. Then save in the desired format. On a Linux machine, use<alt><printscr>
buttons to save a copy to the Desktop. Move it from there to the desired location.
From a Drawing Draw the image. You may need to use fine nib black marker to get a consistent visible
line. Scan it to produce a .jpg formatted file. Check that the scan is well defined.
3. Convert the Waveform Image File.
There is no need to crop the waveform, Wavemaker autotrace has a crop function built in.
You do have to have the waveform in one of the compatible file formats, either ppm or gif 3 .
On a Windows machine, you can use the Accessories -> Paint program to load the original image
and then save it in the desired format. Wavemaker needs the format in PPM, PGM or GIF format. Paint can
save as GIF, so I’d recommend that.
On a Linux machine, you can use the Imagemagik convert command if necessary to convert the image
to an acceptable format for Wavemaker, eg,
convert foo.jpg foo.ppm
4. Start Wavemaker Start the Wavemaker program. On a Windows machine, double click on the file name
wavemaker.tcl. The program should start.
On a Linux machine, execute in a terminal the command wish wavemaker.tcl &. This will start
wavemaker and return the terminal prompt.
The opening screen should look somewhat like figure 2.
5. Load the File Use the File menu to load the .ppm or .gif formatted image file.
At the present time there is no New function that allows loading a new waveform. You need to exit Wavemaker and start it again.
6. Define the Start and End Points of the Waveform The line-connected circles define the start and end
points of the waveform file. Move the circles horizontally so that one is positioned at the start of the
waveform and the other one at the end of the waveform (figure 3). The vertical position of the circles and
line is unimportant.
7. Setup for Hints Wavemaker needs some hints in order to detect the waveform. To setup for the hints:
• If the waveform image has a grid (as in the example of figure 3) make sure the Grid control is
checked.
• In the bottom of the screen, click on the Hint selector. That provides you with a cursor indicator, a
small circle that will be useful in the next step.
8. Define the Waveform Search Area This is particularly important if you have a lot of extraneous detail
in the waveform image. Figure 4 shows an example. Here the image is a raw screenshot of the CGR-101
oscilloscope with a waveform waveform. We’re only interested in the waveform, so the blue rectangle,
which defines the search area, has been positioned in the oscilloscope screen area.
Here’s how you create this rectangle: Right click in the screen area. A menu appears.
Select Hint -> Add Corner. A blue dot appears on the image. Drag it to one corner of the image.
Repeat, adding a second dot at the opposite corner of the image. With the second dot, a rectangle appears,
defining the search area. Adjust the corners to suit the search region.
3 It is claimed in the manual that Wavemaker can also cope with jpg format if the Tcl Img package is available. I’ve obtained erroneous
results when using jpg formatted files, so I’d advise against it.
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Figure 3: Defining the Start and End of the Waveform File

Figure 4: Defining the Waveform Search Area
9. Describe the Background, Grid and Waveform Colours Now you need to tell Wavemaker the colours of
the background, grid and waveform.
(a) Position the cursor somewhere in the waveform area. Right click and select (left click) Zoom -> 8.
This will expand the image area by a factor of 8, so it’s easy to see the elements of the graph. Move
the sliders so that you can see clear background, grid and waveform.
(b) Position the cursor somewhere over the background. Right click and select Hint -> Background.
The value of the background colour appears in the BG entry in the upper left corner of the GUI.
(c) Position the cursor somewhere over the grid. Right click and select Hint -> Grid. The value of
the grid colour appears in the Grid entry in the upper left corner of the GUI.
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(d) Position the cursor somewhere over the waveform. Right click and select Hint -> Wave. The
value of the waveform colour appears in the Wave entry in the upper left corner of the GUI.
(e) Return the display back to normal magnification: right click and select Zoom ->1.

Figure 5: The Waveform Copy
10. Autotrace! Now for the excitement: select (left click) the Trace button, centre top of the GUI display.
After some thinking, tracing of the waveform appears in a different colour. In the bottom right corner of the
GUI is the Hide Picture control. Click on that to see the tracing by itself.

(a) Before

(b) After

Figure 6: Adjusting Wave Height
If the tracing shows a series of vertical spikes (figure 6(a)), try adjusting increasing the setting of the
Wave Height control. Then click on Trace again and see if that improves matters (figure 6(b)).
11. Generate the Waveform File Right click in the image area and select See Result. Wavemaker adds a
blue trace showing the data that will be saved to the waveform file, figure 5.
12. Cleaning up the Waveform In the case shown in figure 5, the waveform starts on the X-Axis, which is
probably not wanted. Also, if you look closely, there are some glitches and discontinuities which could be
smoothed out.
Figure 7(a) shows an enlarged section of the original waveform. The large negative-going spike in the original is probably an artifact of some kind - noise or interference. Figure 7(b) shows the same area without the
original waveform (using Hide Picture). The red trace in figure 7(b) shows that Wavemaker dutifully
traced the artifact in the original waveform. To edit this out of the final arbitrary waveform file (the blue
trace in figure 7(b)), zoom in to the image and then left-mouse-button-drag each point on the blue trace
vertically to the desired location. You can only drag vertically, and only one point at a time.
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(a) Before

(b) After

Figure 7: Waveform Cleanup
When you have completed all the tweaks to the waveform, save it immediately, so that there is no danger of
it being overwritten or reverted by further processing. Select File -> Save Data and write the data
to the file of your choice.
13. Use the Waveform File in the Generator Move the waveform file that you created to the Source
subdirectory where the Syscomp instrument software is installed. Then start the generator. Use the
Custom Waveform button to load that waveform into the generator memory. Now the generator will
produce that waveform at the amplitude, frequency and offset settings of the generator.

For more information
Consult the excellent and detailed manual by John Foster that accompanies the Wavemaker program.
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