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1 Overview

Wavemaker is a program designed to help with the production of custom (‘User’) wave-
forms for the Syscomp1 WGM-101 waveform generator.

The program’s main feature is a drawing window, in which the mouse can be used to
draw a waveform shape onto a canvas. The drawing can be edited, and the result saved into
a data file compatible with the requirements of the WGM-101.

Although waveforms can be drawn directly by hand, the main purpose of the program
is to allow them to be traced from a scanned picture, which mayfor example be obtained
from a printed or hand-drawn source.

The WGM-101 expects waveform data as a set of 256 sample values, each representing
a voltage level and each in the range 0–255 where 0 representsthe peak positive voltage,
and 255 represents the peak negative voltage. The full set of256 samples describes one
cycle of the waveform. In normal use of the program, the stepsto be followed are:

1. Prepare the background picture of the waveform, using scanner software and/or an
image editor.

2. Run wavemaker, and load the picture.

3. Adjust the horizontal axis marker to span one full cycle ofthe waveform in the pic-
ture.

4. Use the mouse to draw a trace line over the waveform. There is a zoom feature to
make this process easier, and sections of the line can be erased and redrawn until
they’re right.

5. Select the ‘See Result’ mode, which superimposes a histogram-like display of the
sample values calculated from the trace line.

6. If desired, drag individual sample lines vertically to clean up the waveform. This can
be particularly useful if there are vertical edges.

7. Save the result to a data file, which may then be loaded into the WGM-101.

2 Preparing the Background Picture

Note: If you only want to draw a waveform in freehand style, you can omit this step.
The picture needs to be in a file format that the program can handle. Assuming that the

original picture is on paper, the first step is to scan it. The method will obviously depend on
your operating system and what scanner software you have, but the result will be an image
file of some sort.

It’s then usually a good idea to use an image editor program toclean up the result. You
can use something like PhotoShop if you have it. I use The Gimp2, which is free and has
all the needed functionality. It’s available in versions for Linux, Mac and Windows.

It’s not critical, but a useful image size is one in which a cycle of the waveform occupies
500 pixels or so horizontally. You should crop the image to leave a small margin around
the waveform – large margins will cost memory and speed at high zoom levels. The left
and right margins should each be at least 10% of the width of one cycle of the waveform,
to allow the adjustments described in Section 8.1. More than10% does no harm, but is not
necessary.

When you save the result, PPM, PGM or GIF formats will work, oryou could use JPEG
or a pixmap if you have the Tk ‘Img’ package installed. It’s worth making sure that the

1http://www.syscompdesign.com/
2http://www.gimp.org/
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image size is less than your screen size – if it’s larger, I think you’ll find it inconvenient to
work with.

2.1 Working Without a Background Picture

If you don’t use a background picture, you’ll find that the drawing area available to you is
restricted by the window size. Or to put it another way, the scroll bars won’t let you move
outside that area.

If that’s a problem, just use an image editor to prepare a dummy picture which is an
all-white image of the size you’d like to work with. Load thatas the background picture,
and it will give you the space you need.

3 Running the Program

Under Linux, run the program with

cd wherever-you-saved-the-program
wish wavemaker.tcl

On other platforms, do whatever you have to do to run thewavemaker.tcl Tcl/Tk
script. (Anyone want to help me out here?)

When the program starts up, select ‘Load Picture’ from the File menu, and use the file
dialog box to open the file containing the background picture. The picture will appear in
the drawing window, together with the horizontal axis marker. The horizontal axis marker
is a magenta line with a circle at each end.

4 Adjusting the Horizontal Axis Marker

When the program starts up, it will be in ‘Adjust Axis’ mode, as you will see from the
radiobuttons at the bottom of the window. In this mode, the cursor (when the mouse is over
the drawing area) is a small dot. What you need to do is to drag the ends of the axis marker
so that the marker spans exactly one cycle of the waveform in the background picture.

To drag an end of the marker, position the mouse on the rim of the corresponding circle,
and drag that. The end of the axis line (in the middle of the circle) should be positioned on
the waveform.

The vertical offset of the marker doesn’t matter, so you can choose any convenient point
on the waveform to mark the cycle. The marker is not constrained to be horizontal, and
you can use this to compensate if the scanned image is not quite squarely oriented. When
sample values are calculated, the calculation uses the vertical distance between the trace
and the axis marker at each point.

The Options menu has an entry which lets you change the colourof the axis marker if
you wish.

5 Tracing the Waveform

To begin tracing the waveform, select ‘Draw’ mode using the radiobutton at the bottom of
the window. The cursor will change to a pencil, and you can nowuse the mouse to draw a
line on the screen following the waveform shape. The line canextend past the ends of the
axis marker, but only the part within those limits will be used.

Accurate drawing with a mouse is not easy, and you’ll probably want to use the Zoom
menu to magnify the picture. Zoom levels provided are 1, 2, 4 and 8. Use whichever you
find suits you best. Note too that Section 7.2 describes how tozoom in onto a specific point
in the drawing.
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By default, lines you draw will be in red and will be one pixel wide. The Options menu
lets you adjust both colour and width. At high zoom levels, it’s often a good idea to increase
the width.

You don’t have to trace the whole waveform cycle in one drawing stroke. Use as many
strokes as you like, and you can draw them from left to right orfrom right to left. The only
thing that doesn’t make sense is to have strokes that double back on themselves horizon-
tally. If you do draw such a stroke, the program will automatically edit it when you release
the mouse, to remove the overlap. If you don’t like the result, you can erase that part of the
trace and try again.

The strokes you draw don’t have to cover the whole of the waveform, because the
program will fill any gaps using linear interpolation. So if your waveform has straight-line
segments (vertical, horizontal or sloping), just leave them out and the program will generate
them for you. As an example, if you want to create a sawtooth waveform, all you need to
draw is one very short line at the peak.

Drawing strokes are allowed to overlap each other. Where they do, the program will
take an average for the sample value.

6 Editing the Trace

It’s hard to trace a waveform accurately in one attempt, so there’s an ‘Erase’ drawing mode,
selected by the radiobutton at the bottom of the window. In this mode, the cursor changes
to a vertical arrow.

To erase a section of the trace, position the mouse at one end of the section to be erased,
and drag horizontally to the other end of the section. When you press the mouse, a vertical
line appears on the canvas as a marker. As you drag, a second vertical line follows the
mouse. When you release the mouse, whatever is between the lines will be erased.

There’s no ‘Undo’ functionality, so if you accidentally erase too much you have to
redraw it. For a program as simple as this, I didn’t think the ability to undo actions was
worth the effort. If you think otherwise, let me know why it’sa problem and I’ll see what I
can do.

7 Short Cuts

7.1 Mode Switching

When tidying up a trace, you’ll probably be switching frequently between the Draw and
Erase modes. For convenience, there are a couple of short cuts to reduce the mouse travel:

• If you click the middle mouse button anywhere within the drawing area, the drawing
mode will toggle between Draw and Erase. If the mode was one ofthe other modes
(Adjust Axis or See Result), Draw mode will be selected. In case your mouse doesn’t
have a middle button, holding down the shift key while clicking in the drawing area
will have the same effect.

• If you right-click anywhere in the drawing area, you’ll get apopup menu allowing
you to select any drawing mode. This menu duplicates the function of the radiobut-
tons. In case your mouse doesn’t have a right button, holdingdown the control key
while clicking in the drawing area will have the same effect.

7.2 Zooming

When you alter the zoom factor from the Zoom menu, the programtries to keep the point
at the centre of the screen in the same place after the zoom. Ifyou start at zoom factor 1
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(say) and switch to zoom 8, this means you’ll probably have toscroll around afterwards to
find the detail you were looking for.

An alternative method is to right-click (or control-click)to get the popup menu de-
scribed above. The Zoom menu is repeated as a sub-menu in the popup, and when you
select a new zoom factor from it the original point where you clicked the mouse will then
be centred in the screen. This is a much easier way to display the detail you wanted to see.

8 Viewing and Trimming the Result

After tracing the waveform, select the ‘See Result’ drawingmode. This overlays the wave-
form with a histogram (in blue by default, but you can select adifferent colour from the
Options menu). In this mode, the cursor changes to a small cross. The histogram has 256
segments and indicates the sample values calculated from the trace. If your waveform has
sharp edges or other detail features, you can now clean them up by dragging individual
samples up and down on the screen. You will almost certainly want to select a highish
zoom factor for this – otherwise the sample lines will be too small to work with. The Op-
tions menu also has an entry for adjusting the thickness of the histogram lines. The selected
thickness applies to the horizontal sample lines only – the vertical lines joining them are
always one pixel wide.

After displaying the histogram, you can still go back and edit the trace or adjust the
axis. However, after making any such changes the histogram will need to be regenerated,
which will lose any tweaks you may have made to it. So the adjustment of individual
samples does need to be the last task before saving the file.

At the bottom right of the window is a ‘Hide Picture’ button which does what it says.
The button may be useful at this stage, in order to see a clearer view of the histogram.

8.1 The Cycle Transition

You’ll probably want to make sure that the end of the cycle makes a smooth transition to
the start of the next cycle. For this, turn on the ‘Extend Histogram’ item in the Options
menu. This extends the histogram display by 20 samples at each end. At the start, the 20
samples are copied from the end of the waveform, and at the endthe extra 20 samples are
copied from the start. Thus, you can view the transition at either end. If it isn’t smooth,
you can drag individual samples to adjust it or, probably easier, you can go back and edit
the trace line until the transition is acceptable. If you aregoing to edit the trace, be sure to
do it before any edge cleanup. Otherwise, you’ll lose the edge cleanup when the histogram
is regenerated after the trace edit.

8.2 Edges

The very last task before saving the file is to clean up any sharp edges that you may want
in the waveform. It’s easier to do this by dragging individual samples than by editing the
trace line.

9 Controlling the Clutter

By the time you get to the final stage of cleaning up the histogram, you’ll find that it’s
difficult to focus on the superimposed images of the background picture, the trace strokes
you’ve drawn, and the histogram itself. They are, after all,all competing within the same
screen space.

The program tries to help in three ways:
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• Whenever you select the ‘Draw’ or ‘See Result’ drawing modes, the trace or the
histogram respectively will be brought to the foreground. Use this when you want to
concentrate on one or the other.

• The Options menu lets you adjust line colours and thicknesses. This gives you a way
of emphasizing what you currently want to examine, and providing contrast against
other components of the display.

• The ‘Hide Picture’ button lets you suppress the background picture when you want
to concentrate on the other items.

10 Saving the Result

When the histogram is to your liking, it’s time to write the data file. The ‘Save Data’ entry
in the File menu will bring up a dialog box to allow you to name the file, and the save is
then done without further effort.

There is, however, one option you will probably want to consider before saving. The
File menu also contains a checkable item labelled ‘Remove DCon Save’, which affects the
way your data file will be written.

If you save the data without checking the menu item, the waveform will be scaled so
that it uses the full range of sample values (0–255). If the waveform is asymmetric, that
will generally imply that it has a constant DC offset to some extent. If you would like to
remove the DC offset, select the menu item before saving. Theaverage level of the saved
waveform will then be 0V. It won’t use the full range of samplevalues, but it will use as
wide a range as possible.

11 Help Menu

If you’re reading this, then either you’ve figured out the Help menu3 or you’ve otherwise
found and opened themanual.pdf file, because that file is what you’re reading now.

There are two items in the Help menu. The first is the command todisplay the manual,
and the second just tells you the version number of the program. The version number item
doesn’t have any action associated with it, which is why it’spermanently greyed out.

If the help menu gave you a strange error message, then here’ssome detail on what was
supposed to happen.

When the wavemaker program starts up, it looks in the directory containing the script
wavemaker.tcl, and expects to find this PDF manual as the filemanual.pdf. If it
doesn’t find the file, the entry in the Help menu will bring up a dialog box explaining that
the file couldn’t be found.

If the file is found, then the entry in the Help menu is supposedto open and display the
manual using whatever application is appropriate for the operating system under which the
program is being run. The method of opening the file varies depending on your operating
system:

Linux or Mac: The program looks for the presence of a suitable applicationon the system,
using a hard-coded list of possibilities. The first one on thelist that it finds to be
present on the system will be used. If none of the applications on the list is present,
the menu item will bring up a dialog box explaining that an application couldn’t be
found.

Windows: The program uses the supplied ShelExec.exe application to find a suitable PDF
viewer.

3Well, it was hardly rocket science. . .
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Other: If the program didn’t recognize your operating system as oneof the above, the
Help menu will display a message to that effect.

If you got an error message when you tried the Help menu, then please let me know. It
would get a high priority on the bug list.

12 Bugs

12.1 Errors

Well, there aren’t any, of course. But if you think you’ve found one, please do email me,
describing the problem and quoting the program version number (given as the last item in
the Help menu):

john@jsjf.demon.co.uk

If you ask nicely, I’ll see what I can do. . .

12.2 Omissions

I decided not to implement the following potential features. If you think they should be
done, I’m open to discussion. . . .

• There’s no ‘Undo’ feature. Once you’ve made an edit, you can only back it out by
using the erase/draw cycle. Since it takes only about five minutes to do a complete
waveform, I haven’t seen this as a problem.

• There’s no way to save an editing session and return to it later. The reason is the same
as above: editing sessions just don’t take long enough to make the feature necessary.
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